The Joomla! team has recently published Joomla! 1.5 RC3 and is constantly developing Joomla! 1.5 with their limited ressources. In the past we (the VirtueMart Development Team) have tried to make VirtueMart compatible to Joomla! 1.5 with more or less success. Although Joomla! 1.5 provides a "Legacy Plugin" that emulates Joomla! 1.0 functions, it must be said that this doesn't really turn Joomla! 1.5 into a Joomla! 1.0. Some of the legacy functions work differently compared to the original functions in Joomla! 1.0.

After all we have decided to stop our compatibility efforts for VirtueMart 1.0.x and Joomla! 1.5 and just make the upcoming VirtueMart 1.1 compatible to J! 1.5 instead.

So from now on the VirtueMart 1.0.x  series is officially not compatible to Joomla! 1.5 (even not in Legacy mode).

We apologise for any inconvenience this might cause, but currently it's not possible for us to concentrate on development for VirtueMart 1.0.x and VirtueMart 1.1.

When will VirtueMart 1.1 be stable? We will soon publish another beta release, which will bring you the latest state of development for testing (Nightly Builds are available). We need you for making VirtueMart better! Bug Reports are just one part of the game. Our Teams need people. If you feel, you can help us, please apply for a job in one of the new teams.

Comments   

 
#34 Kevin Shayne 2008-02-09 21:43
Have 1.5 latest release and tried putting on latest nightly version of VM 1.10. My Joomla is in legacy mode and cannot install. Tried pulling from legacy mode but still same result.

function-file-p ut errors ---- line 298

Hopefully this will assist someone out there in development land. Like others I'm looking forward to moving off OSC/CRE so that when changes need to be made I no longer need to look to coders.
Report to administrator
 
 
#33 Sören 2008-01-11 07:48
Well,
as we wrote later on, backwards compatibility is actually maintained. There's no need to upgrade to Joomla! 1.5 when using VirtueMart 1.1.
Report to administrator
 
 
#32 Fabrice Dantinne 2008-01-11 06:46
Good decision :-)
backwards compatibility is not necessary.
I m impatient to test the beta version ;-)
Report to administrator
 
 
#31 olaska 2007-12-19 09:15
I've spent too many hours (no sleep) to install VM1.1 with Joomla 1.15 (locally) both automatic and manually but No Way.
The install manual seems to be written for an older version of VM1.1 or install with Joomla 1.13??
Been trying and trying again and again - have I spent to many hours so it all get's mixed up?
Report to administrator
 
 
#30 Paul Bos 2007-12-15 23:20
Hm i know it really takes a lot of time developing a great extension like VM but joomla 1.5 is already out for quite some time now and i want to start working on my new webshop. I can anyone please tell me where to find a beta version allready? If the stable version comes out i will just update.. this way i can at least start on adding products and stuff.
Report to administrator
 
 
#29 Bokkenkopf 2007-12-11 14:11
Still waiting......

Does anybody knows something about the expected releasedate?
Report to administrator
 
 
#28 Grasshopper 2007-12-07 16:38
This is great news and a good decision to stop making it work with the Legacy Plugin.
Better concentrate to 1.1
Report to administrator
 
 
#27 Pally 2007-11-30 13:37
Hi everybody,
great idea to complete Virt 1.1 ...Im just testing Joomla 1.5 and Virt 1.1 ...everything works fine.Only issue I have is logining and 4 steps of order completition... its stopping on step 2 (pressing "continue" and not responding..) Do somebody know how to solve it ???THX.. PS: greetings from Czech Republic!.-)
Report to administrator
 
 
#26 Bokko 2007-11-27 07:38
Hi there,

I really love VirtueMart! I'm allready using it on one of my joomla 1.0.13 sites.
One of my newer sites is running on joomla 1.5rc3 and waiting for VirtueMart 1.5, but I can't wait any longer and maybe have to search for an alternative...

Please can you tell us when V1.5 can be expected?
Report to administrator
 
 
#25 SnazzyD 2007-11-25 23:56
Instead of naming the new version of VM - Virtuemart 1.5... since it is supposed to be a major leap of technology/use, etc... why is it NOT called VM2.0!! THAT way people will NOT associate it with any previous problems or versions!
Report to administrator
 

Add comment


Forum

Subscribe to our News


Delivered by FeedBurner
Virtuemart Newsfeed Counter