Print

VirtueMart 2.0.0 RC3 is released

VirtueMart 2.00 RC3: better, faster and stronger

What is new in VirtueMart RC3?

  • VirtueMart RC3 handles multi-lingual store as a native solution.
  • The plugins implementation has been improved.
  • Joomla cache has been introduced to speed up the code.
  • The number of queries has been reduced.

When is the final?

During one month, several pre-releases for the RC3 have been submitted directly to the members in the forum to test the migration process from the RC2 M version to the RC3, the multi lingual capabilities and the new plugin system. This RC3 version is our last step before the final release. VirtueMart 2.0.0 will be released december, 19th .

Everybody having a store built with a RC2 version should first update their store with this RC3 version. In the final release VirtueMart 2.0.0, all the table migration process will be removed.

How to install the RC3 over a store running RC2 version?

  1. If possible, increase the "max_execution_time" time and the "memory_limit" parameters in your php.ini file, so that the migration / update script gets executed without timing out.
  2. Disable the Akeeba System - System Restore Points.
  3. Disable the Joomla debug option in the Joomla configuration.
  4. Uninstall the vmshipper plugin via the Joomla uninstall menu.
  5. Delete the file virtuemart.cfg placed in the administrator/components/com_virtuemart folder.
  6. Set your default joomla frontend language to the one used in the description of your products. It is important to do this step before updating VirtueMart, to install the correct default VirtueMart languages tables.
  7. Install the component VirtueMart. The code will be overwritten, and VirtueMart tables content will be migrate to the new tables.
  8. Install the AIO component. It contains all the plugins and the modules related to VirtueMart.
  9. Edit and store all your payment methods. All the new tables needed to handle the payment will be created.
  10. Because we have renamed the plugin vmshipper to vmshipment, you must reconfigure the shipment methods.
  11. Go to the administrator, set the language(s) for your store, even if your store is not multi ligual and save the VirtueMart configuration.

How to set up a multi-lingual store?

In addition to the standard Joomla installation, install all languages you would like to use in your multi-lingual store. Select them in the VirtueMart configuration.

Products, categories, manufacturers, shipment, and payment can be translated. All the fields must be stored in the default language. For the others languages , translate only the contents signaled by a flag.

Translators

Some new keys have been added, some languages strings have changed. Now the language files are stable. Please check them or complete them.

Download VirtueMart RC3

Comments   

 
#30 Jef.P 2012-02-23 03:47
Really like the new approach in VM 2.0.0 using it for a new production site now, only thing when using J1.5 you need to install you Joomla language packs before VM to avoiod a few troubles.
Report to administrator
 
 
#29 Gyorgy 2012-01-16 09:17
Please help!

How is it possible to migrate from VM 1.1.9 to 2.0.0 ?
The standard way gives me error message "Failed to retrieve the location of the Patch Package virtuemart.net Server. Probably there's no Patch Package available for your Version. Try again later if you think it's a network problem."

I don't found the patch and I hawe no idea what to do! :sad:
Report to administrator
 
 
#28 txusmi 2011-12-19 18:50
Thanks, thanks, thanks.
Report to administrator
 
 
#27 The Headcrab 2011-12-19 18:35
Thanks for your hard work guys!! We all love your work!
Report to administrator
 
 
#26 The Headcrab 2011-12-19 18:33
2.0 it is! Now imma gonna feed my crabs! :P
Report to administrator
 
 
#25 Lagendijk 2011-12-19 18:29
ThanKs for the final guys!!!!
:-):-):-):-):-):-):-):-):-):-):-):-):-):-):-)
Report to administrator
 
 
#24 Clockworx 24 2011-12-19 17:49
Tik tak tik tak :-)
Report to administrator
 
 
#23 steveshore 2011-12-19 14:10
I get the following message when I have search engine friendly urls enabled.

Joomla 1.7
Virtuemart 2.0 RC3

Quote:
An error has occurred. The requested page cannot be found.
The page also has no styling or template assigned to it when sef urls are enabled either.
Report to administrator
 
 
#22 nemos 2011-12-19 13:53
VirtueMart 2.0.0 will be released december, 19th, 2012.
Report to administrator
 
 
#21 Vero 2011-12-19 13:22
Today? Realy? I´m sitting and waiting...
like other people.
Report to administrator
 

Add comment


Security code
Refresh