New RAM for the Forum Server

Written by Soeren Eberhardt-Biermann on .

forum_screen.jpgAs you might have noticed yesterday, the Forum (and Developer Portal) Server was down from time to time. It was my first day at work after the holidays, so I didn't monitor the server personally. When I attempted to restart CodeBeamer (the great software used for dev.virtuemart.net), it always crashed with a segmentation fault. That error is a good indicator for faulty RAM, so I checked it using memtester. The result clearly showed that the RAM contained bad adresses, so I contacted the Server4you Support team, who quickly replaced the RAM (on the 10 months old server!). So good to know that we can rely on their support...

VirtueMart SVN branches for 1.1, 1.2, and 2.0

Written by Greg on .

Now that VirtueMart 1.1.2 has been released, the VirtueMart team can focus again on the future direction of VirtueMart. In keeping with the VirtueMart road map, we have created separate branches in the SVN repository for the different VirtueMart versions:

VirtueMart 1.1

/branches/virtuemart-1.1 This is the current stable version of VirtueMart. Maintenance releases will be managed here as they are needed.

VirtueMart 1.2

/branches/virtuemart-1.2 This will become the next minor release of VirtueMart containing many new features. VirtueMart 1.2 will maintain compatibility with Joomla! 1.0, Mambo 4.5/4.6, and Joomla! 1.5. PHP 4 will still be supported in VirtueMart 1.2.

VirtueMart 2.0

/trunk This will become the next major release of VirtueMart. VirtueMart 2.0 will only be compatible with Joomla! 1.5 or higher and will only support PHP 5. VirtueMart 2.0 will make extensive use of the Joomla! framework and will provide an extensible architecture to better support third party developers.

Be sure to update your SVN repository paths.

eXtplorer 2.0 gone stable!

Written by Soeren Eberhardt-Biermann on .

extplorer LogoAlthough it hasn't much to do with VirtueMart, I thought I should write about it, because eXtplorer is a valuable tool for so many of you (for me too, I created it, because I needed someting like it!). This software has now been released in version 2.0 (stable) after most of those annyoing bugs have been ironed out.

eXtplorer is a web-based file manager, that allows you to access and work with files directly on your web server. It installs on Joomla! 1.0.x, 1.5.x simply by using the component installer, but it can also be used as a standalone-app. A short word on joomlaXplorer: Although it's still available, I don't develop for it anymore (except for security fixes). eXtplorer is the replacement for joomlaXplorer.

Make sure to check it out:

Upgrading to Joomla! 1.5

Written by Soeren Eberhardt-Biermann on .

Joomla! 1.5 - To upgrade or not to upgrade is the question. Doing the upgrade is not easy - because it's actually not a "simple" upgrade, but a migration. That means you must transfer all your content (and files) from an old Joomla! 1.0.x installation to a new Joomla 1.5 installation using a "migrator component".

To guide you through the basic steps of the migration I have modified and extended a presentation by Sam Moffat and added the steps about how to migrate with VirtueMart to a new Joomla! 1.5 installation.

Let us know your experience on this hot topic.

{GoogleDoc docid="0AZc9AHzAj56vZGhwNmtxeGhfMTlmdmJtdDJjYw" type="presentation" size="m" frameborder="0"}

PS: The Presentation was created using Google Docs and is hosted at Google. It was included on this page using a modified version of the Google Docs Content Plugin.

Remote Installer has been updated

Written by Soeren Eberhardt-Biermann on .

When installing VirtueMart into Joomla!, you mostly need to use the Web Uploader to upload the component and the modules. While the modules are quite small in size, the component installer is about 1.95MB. There has always been a nice possibility to transfer the files directly to your server instead of just downloading them to your computer and re-uploading it to your Server: the VirtueMart Remote Installer.

This remote installer has now been updated for Joomla! 1.5.

Please note that it is not compatible with Joomla! 1.0.

The VirtueMart Remote Installer is a separate component that transfers the component and module installer directly to your server and extracts the arcive - so you can install it from directory instantly.
{rokbox title=|VirtueMart Remote Installer :: Screenshot|}images/stories/screenshots/virtuemart_remoteinstaller.png{/rokbox}

Go an give it a try: Download VirtueMart Remote Installer (36kb).

More Articles ...